summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatej Ľach2023-08-28 19:12:29 +0200
committerMatej Ľach2023-08-28 19:12:29 +0200
commitc7dca92addef6ea1d8adc266d3b2a91de02def8a (patch)
tree9f4099c1d7169ee937426ee69024cdf75083d4c2 /PKGBUILD
downloadaur-c7dca92addef6ea1d8adc266d3b2a91de02def8a.tar.gz
initial release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dfd64a13fcde
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Matej Lach <me@matej-lach.me>
+
+pkgname=dynafire-bin
+pkgver=0.1
+pkgrel=1
+pkgdesc='Real-time threat detection for any Linux system running firewalld, based on real-time updates from the Turris Sentinel project'
+arch=(x86_64)
+url='https://github.com/MatejLach/dynafire'
+license=(GPL3)
+depends=('networkmanager' 'firewalld')
+source=("dynafire::https://github.com/MatejLach/dynafire/releases/download/v${pkgver}/dynafire"
+ "dynafire.service")
+sha256sums=("f4ea7cda7bfa77de7c476b1ef15cc3284f6a59188123f640e30726dcf0a4167c"
+ "2e813ea127bdfa44112d356efb3fe7b03c8d0658e1bb06e7f566435c4ae5d6bb")
+install=dynafire.install
+
+package() {
+ install -d "${pkgdir}/usr/bin"
+ install -m 755 dynafire "${pkgdir}/usr/bin/"
+ chmod +x "${pkgdir}/usr/bin/dynafire"
+
+ install -Dm0644 dynafire.service "$pkgdir"/usr/lib/systemd/system/dynafire.service
+}