summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJon Eyolfson2015-08-21 19:41:51 -0400
committerJon Eyolfson2015-08-21 19:41:51 -0400
commit5e0726c6b205be186782e535c3aebc492d8e9756 (patch)
tree8c38b7a265aa0f230ab1039c2746267630f7d59c /PKGBUILD
downloadaur-5e0726c6b205be186782e535c3aebc492d8e9756.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd5f5e5d4df4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Jonathan Eyolfson <jon@eyl.io>
+pkgname=dynamorio
+pkgver=5.0.0
+pkgrel=1
+pkgdesc="Foo is an example package for this PKGBUILD file."
+url="http://dynamorio.org"
+arch=('x86_64' 'i686')
+license=('BSD')
+depends=()
+optdepends=()
+makedepends=('cmake' 'perl')
+conflicts=()
+replaces=()
+backup=()
+source=("https://github.com/DynamoRIO/dynamorio/archive/release_${pkgver//./_}.tar.gz")
+sha256sums=('0ce079bc2717cbf9da1a8c3fb528c1c5c1469f7b709c9e4f01e117b75f40b36a')
+
+build() {
+ cd "${srcdir}/${pkgname}-release_${pkgver//./_}" && mkdir build && cd build
+ cmake .. -DDISABLE_WARNINGS=ON \
+ -DINSTALL_PREFIX=/opt/dynamorio \
+ -DBUILD_TOOLS=ON \
+ -DBUILD_SAMPLES=ON \
+ -DCMAKE_INSTALL_PREFIX="${pkgdir}/opt/dynamorio"
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-release_${pkgver//./_}/build"
+ make install
+ cd "${pkgdir}"
+ install -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ mv opt/dynamorio/License.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}