summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorslawekwaga2023-05-13 09:06:54 +0200
committerslawekwaga2023-05-13 09:06:54 +0200
commit99bc7ec53d4d29d2285c6ba028998f1a42cde099 (patch)
treefc19c11dc5ffea51779dfbaa7a54f4087e19d458 /PKGBUILD
parent60b86f6e857b26274ef770d3ac1c6a853361e9e7 (diff)
downloadaur-99bc7ec53d4d29d2285c6ba028998f1a42cde099.tar.gz
Updated to 9.0.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4d7bc100c691..69b35fa805e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,6 @@
# Maintainer: Jonathan Eyolfson <jon@eyl.io>
pkgname=dynamorio
-pkgver=7.1.0
-_pkgver=7.1.0-1
+pkgver=9.0.1
pkgrel=1
pkgdesc="A dynamic binary instrumentation framework"
url="http://dynamorio.org"
@@ -13,14 +12,18 @@ makedepends=()
conflicts=()
replaces=()
backup=()
-source=("https://github.com/DynamoRIO/dynamorio/releases/download/release_${pkgver}/DynamoRIO-Linux-${_pkgver}.tar.gz")
-sha256sums=('46da89f507881d1da38113b2fd8aa0d85dacfa94cca67ac9f6551b974386100c')
+source=("https://github.com/DynamoRIO/dynamorio/releases/download/release_${pkgver}/DynamoRIO-Linux-${pkgver}.tar.gz")
+sha256sums=('90452768bda1ee9f123f86a916ecb0a442c59bade36d999de73f759c4f79e6e7')
package() {
- cd "${srcdir}/DynamoRIO-Linux-${_pkgver}"
+ cd "${srcdir}/DynamoRIO-Linux-${pkgver}"
install -d "${pkgdir}/usr/share/licenses/${pkgname}"
mv License.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -d "${pkgdir}/opt/dynamorio"
cp -a * ${pkgdir}/opt/dynamorio
+
+ find ${pkgdir}/opt/dynamorio/ -type f -executable -exec chmod 755 {} \;
+ find ${pkgdir}/opt/dynamorio/ -type f -not -executable -exec chmod 644 {} \;
+ find ${pkgdir}/opt/dynamorio/ -type d -exec chmod 755 {} \;
}