summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJon Eyolfson2015-08-23 21:12:14 -0400
committerJon Eyolfson2015-08-23 21:12:14 -0400
commitadbec8c35247b068a63db2e3294569a45bb3ba64 (patch)
treeb707f4e56ab38cbb1c63f0a5217cc39d10e98b90 /PKGBUILD
parentafb161cc836ccb5a3fa93887f10eda81da8b56a6 (diff)
downloadaur-adbec8c35247b068a63db2e3294569a45bb3ba64.tar.gz
Update to 5.0.0-3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 14 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 67db26f2b3ba..53f0c095ef39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,30 @@
# Maintainer: Jonathan Eyolfson <jon@eyl.io>
pkgname=dynamorio
pkgver=5.0.0
-pkgrel=2
+_pkgver=5.0.0-9
+pkgrel=3
pkgdesc="A dynamic binary instrumentation framework"
url="http://dynamorio.org"
arch=('x86_64' 'i686')
license=('BSD')
depends=()
optdepends=()
-makedepends=('cmake' 'perl')
+makedepends=()
conflicts=()
replaces=()
backup=()
-source=("https://github.com/DynamoRIO/dynamorio/archive/release_${pkgver//./_}.tar.gz")
-sha256sums=('0ce079bc2717cbf9da1a8c3fb528c1c5c1469f7b709c9e4f01e117b75f40b36a')
-
-build() {
- cd "${srcdir}/${pkgname}-release_${pkgver//./_}" && mkdir build && cd build
- cmake .. -DDISABLE_WARNINGS=ON \
- -DINSTALL_PREFIX=/opt/dynamorio \
- -DBUILD_TOOLS=ON \
- -DBUILD_SAMPLES=ON \
- -DCMAKE_INSTALL_PREFIX="${pkgdir}/opt/dynamorio"
- make -j
-}
+source=("http://dl.bintray.com/bruening/DynamoRIO/DynamoRIO-Linux-${_pkgver}.tar.gz")
+sha256sums=('2b9ec200e2113f78ceb04c73e6bc9f74049d12a8a2e1f1dda1d23bf905e04057')
package() {
- cd "${srcdir}/${pkgname}-release_${pkgver//./_}/build"
- make install
-
- chmod 755 "${pkgdir}/opt/dynamorio/lib64/release/libdynamorio.so.4.2"
-
- cd "${pkgdir}"
+ cd "${srcdir}/DynamoRIO-Linux-${_pkgver}"
install -d "${pkgdir}/usr/share/licenses/${pkgname}"
- mv opt/dynamorio/License.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ mv License.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ install -d "${pkgdir}/opt/dynamorio"
+ chmod 755 lib32/debug/libdynamorio.so.5.0
+ chmod 755 lib64/debug/libdynamorio.so.5.0
+ chmod 755 lib32/release/libdynamorio.so.5.0
+ chmod 755 lib64/release/libdynamorio.so.5.0
+ cp -a * ${pkgdir}/opt/dynamorio
}