summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJon Eyolfson2015-10-08 19:42:23 +0200
committerJon Eyolfson2015-10-08 19:42:23 +0200
commitc60ba2af8519e684982bf89eac4d5648db9a3914 (patch)
tree32c8692add1288ed04db32ba53a981af2c8c20e2 /PKGBUILD
parentadbec8c35247b068a63db2e3294569a45bb3ba64 (diff)
downloadaur-c60ba2af8519e684982bf89eac4d5648db9a3914.tar.gz
Update to 6.0.0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 53f0c095ef39..bde2c470e7c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Jonathan Eyolfson <jon@eyl.io>
pkgname=dynamorio
-pkgver=5.0.0
-_pkgver=5.0.0-9
-pkgrel=3
+pkgver=6.0.0
+_pkgver=6.0.0-6
+pkgrel=1
pkgdesc="A dynamic binary instrumentation framework"
url="http://dynamorio.org"
arch=('x86_64' 'i686')
@@ -13,8 +13,8 @@ makedepends=()
conflicts=()
replaces=()
backup=()
-source=("http://dl.bintray.com/bruening/DynamoRIO/DynamoRIO-Linux-${_pkgver}.tar.gz")
-sha256sums=('2b9ec200e2113f78ceb04c73e6bc9f74049d12a8a2e1f1dda1d23bf905e04057')
+source=("https://github.com/DynamoRIO/dynamorio/releases/download/release_6_0_0/DynamoRIO-Linux-${_pkgver}.tar.gz")
+sha256sums=('ae24c4e53d15e065e82c342d4ee61a3f06e29a65e95bbcc854017daf996000da')
package() {
cd "${srcdir}/DynamoRIO-Linux-${_pkgver}"
@@ -22,9 +22,9 @@ package() {
mv License.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -d "${pkgdir}/opt/dynamorio"
- chmod 755 lib32/debug/libdynamorio.so.5.0
- chmod 755 lib64/debug/libdynamorio.so.5.0
- chmod 755 lib32/release/libdynamorio.so.5.0
- chmod 755 lib64/release/libdynamorio.so.5.0
+ chmod 755 lib32/debug/libdynamorio.so.6.0
+ chmod 755 lib64/debug/libdynamorio.so.6.0
+ chmod 755 lib32/release/libdynamorio.so.6.0
+ chmod 755 lib64/release/libdynamorio.so.6.0
cp -a * ${pkgdir}/opt/dynamorio
}