summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBobby Hamblin2023-10-08 12:08:44 -0600
committerBobby Hamblin2023-10-08 12:08:44 -0600
commit0d190cfacf711b49957fece5227016fbedb1ad6b (patch)
tree8afe3d3b6b0218c00c0bd3afb7c07a01ca57e536 /PKGBUILD
downloadaur-0d190cfacf711b49957fece5227016fbedb1ad6b.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..60ec3ada96a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Robert Hamblin <hamblingreen@hotmail.com>
+pkgname=dynstr
+pkgver=0.1.0
+pkgrel=1
+pkgdesc=""
+arch=('i686' 'x86_64' 'arm' 'aarch64')
+url="https://gitea.privatedns.org/xavi/dynstr"
+license=('GPL3')
+makedepends=('cmake')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver-rc1.tar.gz")
+sha512sums=('3c83382c8a080d44d5573b007f1f15a7236c4746ade1429b4be825e9c73f51d8b66bee9662cc6b650d17f106015577e48dbd299d52a7cdebb7f2d9bfa1bba4bc')
+
+build() {
+ cd "$pkgname"
+
+ cmake -B build
+ cmake --build build
+}
+
+package() {
+ cd "$pkgname"
+
+ DESTDIR="$pkgdir" cmake --install build
+
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+