summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKonstantin Fedortsov2021-07-28 07:47:49 +0300
committerKonstantin Fedortsov2021-07-28 07:47:49 +0300
commit147af956895794ecaae822ef38712190c8592c57 (patch)
treea255fa2886097d9794a1ad7826615c69b15f040e /PKGBUILD
parentafe6c2c1b2b3bc61dfe03b390427aa47b93ffe8a (diff)
downloadaur-147af956895794ecaae822ef38712190c8592c57.tar.gz
Validity check error fixed
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ecd7554666e2..ca2a4312ed3e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: istimaldar_sntlk <istimaldar@gmail.com>
pkgname=earthly-bin
pkgver=0.5.20
-pkgrel=1
+pkgrel=2
pkgdesc='Build automation for the container era'
arch=('x86_64')
url='https://earthly.dev'
@@ -13,18 +13,18 @@ depends=(
)
source=(
- "https://github.com/earthly/earthly/releases/download/v${pkgver}/earthly-linux-amd64"
+ "${pkgname}-${pkgver}::https://github.com/earthly/earthly/releases/download/v${pkgver}/earthly-linux-amd64"
)
sha512sums=(
'6624f6dd2b6bccfb99d4811e99353b07965f48349fcd50676e6c2964dddc04f3b41a0b6ae78f27bff83cfdd82bc8997e7ade761705209f63afafa3dbd8451a0c'
)
prepare() {
- chmod +x earthly-linux-amd64
+ chmod +x ${pkgname}-${pkgver}
}
package() {
mkdir -p "${pkgdir}/usr/bin"
- cp "${srcdir}/earthly-linux-amd64" "${pkgdir}/usr/bin/earthly"
+ cp "${srcdir}/${pkgname}-${pkgver}" "${pkgdir}/usr/bin/earthly"
ln -s "${pkgdir}/usr/bin/earthly" "${pkgdir}/usr/bin/earth"
}