summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwillemw122015-06-08 12:00:41 +0200
committerwillemw122015-06-08 12:00:41 +0200
commit4029993d4bfb4ca58826767c6c8b17754ffb71fa (patch)
tree7e8943269b24d6c9d41b6fa95f6716f23edd2f41 /PKGBUILD
downloadaur-4029993d4bfb4ca58826767c6c8b17754ffb71fa.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..69e33e5f122f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: willemw <willemw12@gmail.com>
+# Contributor: Kaspar Bumke <kaspar.bumke@gmail.com>
+
+pkgname=easy_spice
+pkgver=0.6.8
+pkgrel=4
+arch=('i686' 'x86_64')
+pkgdesc="Electronic circuit simulator (SPICE frontend, using gschem for schematics and ngspice as simulator)"
+url="http://easy-spice.sourceforge.net/"
+license="GPL"
+depends=('geda-gaf' 'gtk2' 'ngspice' 'xterm')
+source=(http://downloads.sourceforge.net/sourceforge/easy-spice/$pkgname-$pkgver.tar.gz)
+md5sums=('6ffaab8c2dcdfc30ecdca52f3c8bcded')
+
+build() {
+ cd $pkgname-$pkgver
+ LIBS="$LIBS /lib/libm.so.6" LDFLAGS="$LDFLAGS -lm" ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}
+