summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2023-12-23 16:29:07 +0530
committerHans-Nikolai Viessmann2023-12-23 16:29:07 +0530
commit77ddaeedd5e31353e8ddadf3d0363ce2a38ed937 (patch)
tree19b96205c5af573f2e2f35a8c08c4e4078b0625a /PKGBUILD
parent7a874aa02dffa8e72bae49a418ea3312a34dec34 (diff)
downloadaur-77ddaeedd5e31353e8ddadf3d0363ce2a38ed937.tar.gz
fixup package for python3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 30 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5ca719dae8e9..f41391e80129 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,43 @@
-# Maintainer: Hans-Nikolai Viessmann <hv15 AT hw.ac.uk>
-pkgname='easybuild-framework-git'
-pkgver=3.5.1.r14.g5774d360d
-pkgrel=3
+# Maintainer: Hans-Nikolai Viessmann <hans AT viess DOT mn>
+_pkg='easybuild-framework'
+pkgname="${_pkg}-git"
+pkgver=4.8.2.r41.ga2eaf2365
+pkgrel=1
pkgdesc="A software build and installation framework for HPC systems (development)"
arch=('any')
-groups=('easybuild-git')
url="https://github.com/easybuilders"
-license=('GPL')
-depends=('python2' 'python2-vsc-base' 'env-modules-tcl')
+license=('GPL2')
+depends=('python' 'env-modules-tcl' 'python-setuptools' 'python-distro'
+ 'python-yaml' 'python-configobj' 'python-packaging'
+ 'python-humanfriendly' 'python-requests')
optdepends=('lmod: another module management tool'
'fpm: Generate packages of your modules to be installed later'
- 'easybuild-easyconfigs-git: collection of build parameters'
- 'easybuild-easyblocks-git: collection of module recipes')
-makedepends=('git' 'python2-setuptools')
-source=('git+https://github.com/easybuilders/easybuild-framework.git#branch=develop')
+ 'easybuild-easyconfigs: collection of build parameters'
+ 'easybuild-easyblocks: collection of module recipes'
+ 'python-gitpython: for using Git with EasyBuild'
+ 'graphviz: for building nice looking dependency graphs'
+ 'python-keyring: for handling authentication with GitHub'
+ 'python-rich: lets EasyBuild show rich-output, i.e. nice progress bars')
+makedepends=('git')
+provides=("${_pkg}")
+source=("git+https://github.com/easybuilders/${_pkg}.git#branch=develop")
md5sums=('SKIP')
pkgver() {
- cd "$srcdir/easybuild-framework"
+ cd "$srcdir/$_pkg"
printf "%s" "$(git describe --long | sed 's/\([^-]*-g\)/r\1/;s/.*v\(.*\)$/\1/;s/-/./g')"
}
+prepare() {
+ git -C "$srcdir/$_pkg" clean -dfx
+}
+
+build() {
+ cd "$srcdir/$_pkg"
+ python setup.py build
+}
+
package() {
- cd "$srcdir/easybuild-framework"
- python2 setup.py install --root "$pkgdir"
+ cd "$srcdir/$_pkg"
+ python setup.py install --root="$pkgdir" --optimize=1
}