summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authornezumisama2015-11-04 20:22:56 +0100
committernezumisama2015-11-04 20:22:56 +0100
commit3d16f0584c8cf0ade6c181cb56c12d7abe2e17b7 (patch)
tree687f2451cb6999a89677f6c58cbdb54bd2b4a516 /PKGBUILD
downloadaur-3d16f0584c8cf0ade6c181cb56c12d7abe2e17b7.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..161ebd016c8c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: AppleBloom <rat.o.drat@gmail.com>
+
+_pkgname="easystroke"
+pkgname="$_pkgname-git"
+pkgver="0.6.0.r7.g72eaf61"
+pkgrel=1
+pkgdesc="Gesture-recognition application for X11."
+arch=("i686" "x86_64")
+url="https://github.com/thjaeger/easystroke/wiki"
+license=("custom")
+depends=("gtkmm3" "boost-libs" "libxtst" "dbus-glib" "xorg-server")
+makedepends=("boost" "inputproto" "intltool" "gettext" "xorg-server-devel" "help2man")
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+install="$_pkgname.install"
+source=("git+https://github.com/thjaeger/easystroke.git"
+ "sigc.patch"
+ "dont-ignore-xshape-when-saving.patch"
+ "add-toggle-option.patch")
+md5sums=("SKIP"
+ "25fb4b21e36501276285caa788e1acd0"
+ "b9cd799d59ec868371e8e6c538d43bf6"
+ "39013c97c368735967a2f6897c96d614")
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long | sed "s/\([^-]*-g\)/r\1/;s/-/./g"
+}
+
+prepare() {
+ cd "$_pkgname"
+ for patch in ../*.patch
+ do
+ patch -i "$patch"
+ done
+}
+
+build() {
+ cd "$_pkgname"
+ make
+ make man
+}
+
+package() {
+ cd "$_pkgname"
+ make PREFIX="/usr" DESTDIR="$pkgdir" install
+ install -Dm644 "$_pkgname.1" "$pkgdir/usr/share/man/man1/$_pkgname.1"
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: