summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Trotman2016-12-28 18:33:24 +1100
committerChris Trotman2016-12-28 18:33:24 +1100
commitd491793ee3693d366f5a1f5dbf20cbd9ad139897 (patch)
tree1d4712a7755cbf94ca8c0b536cfeafffdc09fb32 /PKGBUILD
downloadaur-ec2-fzf.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e19415547ecd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Chris Trotman <chris+aur@trotman.io>
+
+pkgname=ec2-fzf
+pkgver=1.0
+pkgrel=1
+pkgdesc="Quickly get the address details of ec2 instances"
+url='https://github.com/solarnz/ec2-fzf'
+arch=('x86_64')
+license=('MIT')
+makedepends=('go' 'git')
+conflicts=('ec2-fzf-bin')
+_gourl=github.com/solarnz
+source=("${pkgname}::git+https://${_gourl}/${pkgname}.git#tag=v${pkgver}")
+sha256sums=('SKIP')
+
+prepare() {
+ mkdir -p "${srcdir}/src/${_gourl}"
+ rm -rf "${srcdir}/src/${_gourl}/${pkgname}"
+ mv -f "${pkgname}" "${srcdir}/src/${_gourl}/${pkgname}"
+}
+
+build() {
+ msg2 "Build program"
+ cd "${srcdir}/src/${_gourl}/${pkgname}"
+ cd "cmd/ec2-fzf"
+ GOPATH="${srcdir}" PATH="${srcdir}/bin:${PATH}" go install
+}
+
+package() {
+ cd "${srcdir}/bin"
+ install -Dm755 ec2-fzf "${pkgdir}/usr/bin/ec2-fzf"
+}