summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTobias Borgert2019-06-14 17:13:07 +0200
committerTobias Borgert2019-06-14 17:13:07 +0200
commit19d46866187c3393e3bce041725fbddc1b0d1852 (patch)
tree8beebac74861ac2b90149489bd18b277133fa621 /PKGBUILD
parent83e011c89ed0861cbe3c369ec36cbffbd26bcb6c (diff)
downloadaur-19d46866187c3393e3bce041725fbddc1b0d1852.tar.gz
Combine all cmake scripts in /usr/lib/cmake/ so that developing with cmake
and eCAL works as expected (find_package() etc.).
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b20a7696ba54..ab982f3a2177 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=ecal
pkgver=5.3.2
-pkgrel=8
+pkgrel=9
pkgdesc="enhanced Communication Abstraction Layer"
arch=('x86_64')
url="https://github.com/continental/ecal"
@@ -28,14 +28,15 @@ build() {
cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
-DECAL_THIRDPARTY_BUILD_PROTOBUF=OFF
- make
+ make -j
}
package() {
cd $pkgname-$pkgver
cd _build
DESTDIR="$pkgdir" make install
- mv "$pkgdir/usr/lib" "$pkgdir/usr/lib32"
- mv "$pkgdir/usr/lib64" "$pkgdir/usr/lib"
+ mv "$pkgdir/usr/lib/cmake/"* "$pkgdir/usr/lib64/cmake/"
+ rm -r "$pkgdir/usr/lib"
+ mv "$pkgdir/usr/lib64/" "$pkgdir/usr/lib"
mv "$pkgdir/usr/etc" "$pkgdir/etc"
}