summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTobias Borgert2019-06-13 19:55:32 +0200
committerTobias Borgert2019-06-13 19:55:32 +0200
commitb023c086661495fd32f80485b1784ed124032f53 (patch)
tree6cf5c158f83e3d26eb9ea5acbeccf6596c7124f7 /PKGBUILD
parentf3e83648e94f518c8db4fcf03c76b3bff2faaf8c (diff)
downloadaur-b023c086661495fd32f80485b1784ed124032f53.tar.gz
Set the version string correctly via sed until upstream provides a solution for isolated builds.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 919c280af70c..170948feb3de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=ecal
pkgver=5.3.2
-pkgrel=5
+pkgrel=6
pkgdesc="enhanced Communication Abstraction Layer"
arch=('x86_64')
url="https://github.com/continental/ecal"
@@ -22,11 +22,12 @@ prepare() {
build() {
cd $pkgname-$pkgver
+ sed -i /set\(eCAL_VERSION_STRING\ /s/\$\{eCAL_VERSION_MAYOR\}.\$\{eCAL_VERSION_MINOR\}.\$\{eCAL_VERSION_PATCH\}/"$pkgver"/g CMakeLists.txt
mkdir -p _build
cd _build
cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
- -DECAL_THIRDPARTY_BUILD_PROTOBUF=OFF
+ -DCMAKE_BUILD_TYPE=Release \
+ -DECAL_THIRDPARTY_BUILD_PROTOBUF=OFF
make
}