summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTobias Borgert2019-06-12 22:02:40 +0200
committerTobias Borgert2019-06-12 22:02:40 +0200
commitd88fc93eb7d64ed0e5b8d80691b1358c242bd910 (patch)
tree5ff87d7eaac5fa86ea7c8fc06566f83d185f6d25 /PKGBUILD
downloadaur-d88fc93eb7d64ed0e5b8d80691b1358c242bd910.tar.gz
Initial commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..30562c5fda6c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Tobias Borgert <tobias.borgertt@gmail.com>
+
+pkgname=ecal
+pkgver=5.3.2
+pkgrel=1
+pkgdesc="enhanced Communication Abstraction Layer"
+arch=('x86_64')
+url="https://github.com/continental/ecal"
+license=('Apache')
+depends=('asio' 'protobuf' 'qt5-base' 'simpleini' 'tclap')
+makedepends=('cmake')
+optdepends=()
+source=(https://github.com/continental/ecal/archive/v$pkgver.tar.gz
+ ecal-v5.3.2-archlinux-fabs.patch)
+sha256sums=('cde3b92df167640e94e60bd0a6eff4f6520b43b27059568694283b07250f892c'
+ 'bbbb519e72f177c03a10a6d5fc820e4aebba91de965ccf3e8176ea1851e427c6')
+
+prepare() {
+ cd $pkgname-$pkgver
+ patch --forward --strip=1 --input="../ecal-v5.3.2-archlinux-fabs.patch"
+}
+
+build() {
+ cd $pkgname-$pkgver
+ mkdir -p _build
+ cd _build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DGIT_REVISION_MAYOR=5 \
+ -DGIT_REVISION_MINOR=3 \
+ -DGIT_REVISION_PATCH=2 \
+ -DECAL_THIRDPARTY_BUILD_PROTOBUF=OFF
+ make -j
+}
+
+package() {
+ cd $pkgname-$pkgver
+ cd _build
+ DESTDIR="$pkgdir" make install
+ mv "$pkgdir/usr/lib" "$pkgdir/usr/lib32"
+ mv "$pkgdir/usr/lib64" "$pkgdir/usr/lib"
+}