summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbar0metr2018-08-01 20:17:56 +0500
committerbar0metr2018-08-01 20:17:56 +0500
commit30053543656ecf7455ffe9ed7d71f825b54483fd (patch)
treeec97c284d0a43564eac71df0e35f95a19bf21876 /PKGBUILD
downloadaur-30053543656ecf7455ffe9ed7d71f825b54483fd.tar.gz
Initial
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06293d15bd69
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: bar0metr <admin@os-admin.ru>
+pkgname=ecap-adapter-sample
+_pkgname=ecap_adapter_sample
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='The sample contains three basic adapters (minimal,passthru,modifying,async). Include patches for successful compile and use `modifying` adapter to modify the contents of the whole file'
+arch=('x86_64')
+url='http://www.e-cap.org/archive/ecap_adapter_sample-1.0.0.tar.gz'
+provides=("$pkgname")
+conflicts=("$pkgname")
+source=("$pkgname::$url")
+depends=('libecap')
+license=('GPL')
+
+sha256sums=('SKIP')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ chmod +x ./configure
+ ./configure
+ make -j$(nproc)
+}
+
+package() {
+ cd "$srcdir"
+ make -C "$_pkgname-$pkgver" DESTDIR="$pkgdir" install
+}
+