summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJingbei Li2018-03-07 21:57:45 +0800
committerJingbei Li2018-03-07 21:57:45 +0800
commit2a3ea91fc5f35c0644a6a667f53d3086d4361731 (patch)
tree1726a823b90594ea747e5d7ab02b666553a6dccd /PKGBUILD
parent0da83c10e3647d9b51abde2eaa3f10e197345930 (diff)
downloadaur-2a3ea91fc5f35c0644a6a667f53d3086d4361731.tar.gz
fix plantuml issue
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1105237cb15c..74c3c9306667 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
# Contributor: Andrea Fagiani <andfagiani_at_gmail_dot_com>
pkgname=eclim
pkgver=2.7.1
-pkgrel=1
+pkgrel=2
pkgdesc="Brings Eclipse functionality to Vim"
url="http://eclim.org/"
license=('GPL3')
arch=(i686 x86_64)
depends=('vim' 'eclipse' 'java-environment')
-makedepends=('apache-ant' 'python2-sphinx' 'groovy')
+makedepends=('apache-ant' 'python2-sphinx' 'python2-docutils' 'groovy')
optdepends=('eclipse-pdt: Eclipse PHP Development Tools support'
'eclipse-cdt: Eclipse C/C++ Plugin support'
'eclipse-dltk-core: Eclipse Dynamic Languagues Toolkit support'
@@ -33,6 +33,9 @@ prepare() {
source /etc/profile.d/apache-ant.sh
chmod +x org.eclim/nailgun/configure bin/sphinx
+
+ # Sphinx 1.6 => 1.7 compatibility issue
+ sed 's|sphinx.util.compat|docutils.parsers.rst|' -i doc/extension/plantuml.py
}
build() {