summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJingbei Li2018-11-01 14:44:13 +0800
committerJingbei Li2018-11-01 14:44:39 +0800
commitc00b20bfa5f958ee194f00d4bbfd709d98d1f343 (patch)
tree9f3c93fce6631eea783ba58a4cc06ff5da0f7a5a /PKGBUILD
parentf65d723e974e0a402f359ac3411b03988ca01476 (diff)
downloadaur-c00b20bfa5f958ee194f00d4bbfd709d98d1f343.tar.gz
minor fixes
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 3 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 362a8d2f4392..e52981b8fdb6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,14 @@
# Contributor: Andrea Fagiani <andfagiani_at_gmail_dot_com>
pkgname=eclim
pkgver=2.8.0
-pkgrel=1
+pkgrel=2
pkgdesc="Brings Eclipse functionality to Vim"
url="http://eclim.org/"
license=('GPL3')
arch=(i686 x86_64)
depends=('eclipse' 'java-environment=8' 'libnsl' 'vim')
makedepends=('apache-ant' 'python2-sphinx' 'python2-docutils' 'groovy')
-optdepends=('eclipse-pdt: Eclipse PHP Development Tools support'
- 'eclipse-cdt: Eclipse C/C++ Plugin support'
- 'eclipse-dltk-core: Eclipse Dynamic Languagues Toolkit support'
- 'eclipse-dltk-ruby: Eclipse Ruby support'
- 'eclipse-wtp: Eclipse Web Developer Tools support')
+optdepends=('eclipse-dltk-core')
conflicts=('eclim-git')
install=$pkgname.install
source=("https://github.com/ervandew/eclim/releases/download/$pkgver/${pkgname}_$pkgver.tar.gz")
@@ -29,9 +25,6 @@ prepare() {
-e '68,88d' \
-i ant/build.gant
- # Get the ANT_HOME environment variable
- source /etc/profile.d/apache-ant.sh
-
chmod +x org.eclim/nailgun/configure bin/sphinx
# Sphinx 1.6 => 1.7 compatibility issue
@@ -51,6 +44,7 @@ build() {
cd ../..
+ JAVA_HOME=/usr/lib/jvm/java-8-openjdk \
ant -lib /usr/share/groovy/lib \
-Declipse.home=/usr/lib/eclipse \
-Dvim.files=/usr/share/vim/vimfiles \