summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorArthur Zamarin2015-06-08 11:42:34 +0300
committerArthur Zamarin2015-06-08 11:42:34 +0300
commitf30e8820954a3d615aa9f8b0c5cc013c934891ba (patch)
treeac8b61a322555dc9d0ee97dffcd2b4bcb983b756 /PKGBUILD
downloadaur-f30e8820954a3d615aa9f8b0c5cc013c934891ba.tar.gz
Initial Commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..00b8f4e30eb4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Shanto <shanto@hotmail.com>
+# Contributor: Jonathan Wiersma <archaur at jonw dot org>
+
+pkgname=eclipse-dltk-xotcl
+pkgver=5.0.0
+pkgrel=1
+_pkgdate=201306060709
+pkgdesc="XOTcl IDE for Eclipse"
+arch=('i686' 'x86_64')
+url="http://www.eclipse.org/dltk/"
+license=('EPL')
+depends=("eclipse-dltk-tcl")
+_mirror="http://www.eclipse.org/downloads/download.php?r=1&file="
+source=("$_mirror/technology/dltk/downloads/drops/R${pkgver:0:3}/R-${pkgver:0:3}-$_pkgdate/${pkgname#eclipse-}-I-$_pkgdate.zip")
+md5sums=('b8cddb0cdd5fc7363bb3ba4f4727d32b')
+
+package() {
+ _dest=$pkgdir/usr/share/eclipse/dropins/${pkgname#eclipse-}/eclipse
+ cd $srcdir
+ install -dm755 $_dest
+ find plugins features -type f -exec install -Dm644 {} \
+ $_dest/{} \;
+ # DLTK requires features/*.jar files extracted
+ find $_dest/features -type f -name '*.jar' | while read f; do
+ install -dm755 ${f%*.jar} && cd ${f%*.jar}
+ jar xf $f && rm $f
+ done
+}