summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThomas Weißschuh2012-12-09 16:54:54 +0000
committerThomas Weißschuh2012-12-09 16:54:54 +0000
commitfaf751fc828771ef3b2ca42c11a7054c878c87a5 (patch)
treea9000531bb77e9944de45fac50c2f873feb29698 /PKGBUILD
downloadaur-faf751fc828771ef3b2ca42c11a7054c878c87a5.tar.gz
adopt eclipse-findbugs
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b5496b920b1c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Thomas Weißschuh <thomas t-8ch.de>
+# Contributor: Michael Zoech <michi.zoech+arch at gmail>
+# Contributor: Piotr Beling <qwak@stud.ics.p.lodz.pl>
+
+pkgname=eclipse-findbugs
+pkgver=2.0.1
+_pkgdate=20120712
+pkgrel=1
+pkgdesc="FindBugs plugin for Eclipse"
+arch=('any')
+url="http://findbugs.sourceforge.net/"
+license=('LGPL')
+depends=('eclipse')
+source=("http://downloads.sourceforge.net/project/findbugs/findbugs%20eclipse%20plugin/${pkgver}/edu.umd.cs.findbugs.plugin.eclipse_${pkgver}.${_pkgdate}.zip")
+
+build() {
+ cd "${srcdir}"
+ local dest="${pkgdir}/usr/share/eclipse/dropins/findbugs/eclipse/plugins"
+ install -d "$dest"
+ cp -r "edu.umd.cs.findbugs.plugin.eclipse_${pkgver}.${_pkgdate}" "$dest"
+}
+
+sha256sums=('7025c7874beab02de5459b0a1831af906c9f5de5ba01f2cdedbfc1bd91c2f1ec')