summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOliver Kahrmann2024-01-17 16:20:33 +0100
committerOliver Kahrmann2024-01-17 16:20:33 +0100
commit012a4b8117735436d9f631bfc71127dbd729517c (patch)
tree847dcc91ef83994863da85cb6f716677bf36aa38 /PKGBUILD
parentf6ee4821fbd9fd1b173cc9834eb19c62599edcff (diff)
downloadaur-012a4b8117735436d9f631bfc71127dbd729517c.tar.gz
New maintainer, Update to 2020-03, add desktop file and install icon
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 23 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8a591bd48041..f799d840ad48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,33 @@
-# Maintainer: David Baum <david.baum@naraesk.eu>
+# Maintainer: Oliver Kahrmann <oliver.kahrmann@gmail.com>
+# Contributor: David Baum <david.baum@naraesk.eu>
pkgname=eclipse-installer
-pkgver=1.0
-pkgrel=4
+pkgver=2020.03
+pkgrel=1
pkgdesc="Automates the installation and update of Eclipse development environments"
arch=('i686' 'x86_64')
url="https://wiki.eclipse.org/Eclipse_Installer"
-license=('EPL')
-groups=()
-depends=()
-makedepends=()
-optdepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=()
-changelog=()
-source=('https://mirrors.dotsrc.org/eclipse//oomph/products/eclipse-inst-linux64.tar.gz')
-noextract=()
-md5sums=('SKIP')
+license=("EPL")
+depends=("java-runtime>=8" "unzip" "webkit2gtk")
+options=(!strip)
+source=(
+ 'https://mirrors.dotsrc.org/eclipse//oomph/epp/2020-03/R/eclipse-inst-linux64.tar.gz'
+ 'eclipse-installer.desktop'
+)
+sha1sums=(
+ '07123867ddd4f683747f37cca9ea7e8dc3f16e65'
+ SKIP
+)
package() {
install -d ${pkgdir}/opt/${pkgname}
- cp -a ./* ${pkgdir}/opt/
- rm ${pkgdir}/opt/eclipse-inst-linux64.tar.gz
-
+ cp -a ./eclipse-installer/* ${pkgdir}/opt/${pkgname}
+
install -d ${pkgdir}/usr/bin/
ln -s /opt/${pkgname}/eclipse-inst ${pkgdir}/usr/bin/${pkgname}
+
+ install -d ${pkgdir}/usr/share/icons/hicolor/256x256/apps
+ cp ./eclipse-installer/icon.xpm ${pkgdir}/usr/share/icons/hicolor/256x256/apps/eclipse-installer.xpm
+
+ install -d ${pkgdir}/usr/share/applications
+ cp ./eclipse-installer.desktop ${pkgdir}/usr/share/applications/.
}