summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOliver Kahrmann2024-01-17 16:28:08 +0100
committerOliver Kahrmann2024-01-17 16:28:08 +0100
commit93e925e252bf6bd4a9593f4210552770df50ba74 (patch)
tree3916a95295b3fb96481ac4002b718ec9e78a0b77 /PKGBUILD
parent82c6a40f891568f60f7a263b433d27794cbdd0fa (diff)
downloadaur-93e925e252bf6bd4a9593f4210552770df50ba74.tar.gz
Link, not copy, icon and docs
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1bfe4af5fbfa..2f4586d28c9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: David Baum <david.baum@naraesk.eu>
pkgname=eclipse-installer
pkgver=2020.03
-pkgrel=2
+pkgrel=3
pkgdesc="Automates the installation and update of Eclipse development environments"
arch=('i686' 'x86_64')
url="https://wiki.eclipse.org/Eclipse_Installer"
@@ -26,8 +26,11 @@ package() {
ln -s /opt/${pkgname}/eclipse-inst "${pkgdir}"/usr/bin/${pkgname}
install -d "${pkgdir}"/usr/share/icons/hicolor/256x256/apps
- cp "${srcdir}"/eclipse-installer/icon.xpm "${pkgdir}"/usr/share/icons/hicolor/256x256/apps/eclipse-installer.xpm
+ ln -s "${srcdir}"/eclipse-installer/icon.xpm "${pkgdir}"/usr/share/icons/hicolor/256x256/apps/eclipse-installer.xpm
install -d "${pkgdir}"/usr/share/applications
cp "${srcdir}"/eclipse-installer.desktop "${pkgdir}"/usr/share/applications/.
+
+ install -d "${pkgdir}"/usr/share/doc/${pkgname}
+ ln -s /opt/${pkgname}/readme/readme_eclipse.html "${pkgdir}"/usr/share/doc/${pkgname}/readme_eclipse.html
}