summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Baum2018-01-11 12:10:24 +0100
committerDavid Baum2018-01-11 12:10:24 +0100
commit97d7c3753c892fac74da6aafdec2dd873cf41840 (patch)
treebd74531e8ffaa15492f6de646f3b5f6dd9953c0a /PKGBUILD
downloadaur-97d7c3753c892fac74da6aafdec2dd873cf41840.tar.gz
initial release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d5453c39ce8d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: David Baum <david.baum@naraesk.eu>
+pkgname=eclipse-installer
+pkgver=1.0
+pkgrel=1
+pkgdesc="Automates the installation and update of Eclipse development environments"
+arch=('i686' 'x86_64')
+url="https://wiki.eclipse.org/Eclipse_Installer"
+license=('EPL')
+groups=()
+depends=('')
+makedepends=('')
+optdepends=()
+provides=()
+conflicts=('')
+replaces=()
+backup=()
+options=()
+install=()
+changelog=()
+source=('https://mirrors.dotsrc.org/eclipse//oomph/products/eclipse-inst-linux64.tar.gz')
+noextract=()
+md5sums=('ba8efc2780f6133d8f63678e43bd562c')
+
+package() {
+ install -d ${pkgdir}/opt/${pkgname}
+ cp -a ./* ${pkgdir}/opt/
+ rm ${pkgdir}/opt/eclipse-inst-linux64.tar.gz
+
+ install -d ${pkgdir}/usr/bin/
+ ln -s /opt/${pkgname}/eclipse-inst ${pkgdir}/usr/bin/${pkgname}
+}