summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Nagy2015-06-08 20:26:51 +0200
committerDaniel Nagy2015-06-08 20:26:51 +0200
commit364e75ec8813bd95feff7d005af09fd669f6480e (patch)
tree62a0b13ccb06ca6cf62e367f1f4320da57700698 /PKGBUILD
downloadaur-364e75ec8813bd95feff7d005af09fd669f6480e.tar.gz
import to aur4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..32b208a15f96
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Daniel Nagy <danielnagy at gmx de>
+# Contributor: Tom Vincent <http://tlvince.com/contact/>
+
+pkgname=eclipse-ivyde
+pkgver=2.2.0.final
+_pkgver=${pkgver}-201311091524-RELEASE
+pkgrel=1
+pkgdesc="Eclipse plugin which integrates Apache Ivy's dependency management"
+url="https://ant.apache.org/ivy/ivyde/"
+arch=('any')
+license=('apache')
+depends=('eclipse' 'eclipse-ivyde-ivy')
+source=("http://mirrors.ukfast.co.uk/sites/ftp.apache.org/ant/ivyde/${pkgver}/apache-ivyde-${_pkgver}.tar.gz")
+md5sums=('7bed9c2bcf920e7e29735f62a78495c3')
+
+package() {
+ local dest=${pkgdir}/usr/share/eclipse/dropins/${pkgname/eclipse-}/eclipse
+ mkdir -p $dest
+ tar --directory $dest --strip-components=1 --wildcards -xzvf ${srcdir}/apache-ivyde-${_pkgver}.tar.gz "*.jar"
+}