summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2020-03-30 17:22:25 +0200
committerhaawda2020-03-30 17:22:25 +0200
commitb95a4c8bf347a4569f2956913bf0659959bcae5a (patch)
treedf464f49d43346b0a4014cfa0cf236abc46ee661 /PKGBUILD
parent4e6ad6914c17e748a89a60b00c9f1766876225a2 (diff)
downloadaur-b95a4c8bf347a4569f2956913bf0659959bcae5a.tar.gz
adopted and updated
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 20 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4ef8f64a2c41..b5711365fae9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,39 @@
-#Maintainer: William J. Bowman <aur@williamjbowman.com>
+# Contributor: William J. Bowman <aur@williamjbowman.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=ect
-pkgver=0.8.2
-pkgrel=2
-pkgdesc='Efficient Compression Tool (or ECT) is a ++ file optimizer. It supports PNG, JPEG, GZIP and ZIP files.'
+_pkgname=Efficient-Compression-Tool
+pkgver=0.8.3
+pkgrel=1
+pkgdesc='file compressor, supports postcompression of PNG, JPEG, GZIP and ZIP files.'
url='https://github.com/fhanau/Efficient-Compression-Tool'
arch=('i686' 'x86_64')
-license=('Apache2')
-source=("ect::git+https://github.com/fhanau/Efficient-Compression-Tool.git#tag=v${pkgver}")
-sha256sums=('SKIP')
+license=('Apache')
+source=("git+https://github.com/fhanau/Efficient-Compression-Tool.git#commit=f0b38f7f8b750099f14d4976beff6a107d6119ac")
+md5sums=('SKIP')
+depends=('gcc-libs')
makedepends=('nasm' 'git')
-prepare(){
- cd "${srcdir}/${pkgname}/src"
+prepare() {
+ cd ${_pkgname}
+ git submodule init
git submodule update --init --recursive --recommend-shallow
- cd mozjpeg
- autoreconf -i
}
build() {
- cd "${srcdir}/${pkgname}/src"
+ cd ${_pkgname}
+ [ -d build ] || mkdir build
+ cd build
+ cmake -DECT_FOLDER_SUPPORT=off ../src
make
}
package() {
- cd "${srcdir}/${pkgname}/src"
+ cd ${_pkgname}/src
PREFIX=/usr/ DESTDIR="${pkgdir}" make install
- cd "${pkgdir}"/usr/bin
+ cd "${pkgdir}"/usr/bin
# Some things expect this to be an all-caps name
- ln -s ect ECT
+ ln -s ect ECT
}