summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorrevel2019-12-17 03:45:07 +0100
committerrevel2019-12-17 03:45:07 +0100
commit9d8be652456bed92a21f3bbb666464b17c83b826 (patch)
treecd60f12b0aaa3a6009f4c8122741bc0a5adda868 /PKGBUILD
parent3d964094d86888a3c0fb5d155f83b42c23f2be23 (diff)
downloadaur-9d8be652456bed92a21f3bbb666464b17c83b826.tar.gz
- fixes plugin path
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b775d3e033d1..4f1abb328077 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=edb-debugger
pkgver=1.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="EDB (Evan's Debugger) is a cross platform AArch32/x86/x86-64 debugger, inspired by Ollydbg."
arch=('i686' 'x86_64')
url='http://www.codef00.com/projects#debugger'
@@ -13,19 +13,22 @@ depends=('qt5-xmlpatterns' 'qt5-svg' 'capstone>=3.0')
makedepends=('boost>=1.35.0' 'cmake')
optdepends=('graphviz')
source=("https://github.com/eteran/edb-debugger/releases/download/$pkgver/edb-debugger-$pkgver.tgz"
- 'edb.desktop')
+ 'edb.desktop'
+ 'plugin_path.patch')
sha256sums=('f13de8fd3f26fa1210fb0ff50ff756c2de8de51e75770a57aca35df06d6a0187'
- 'f3e725642c6b87d5a7fd25331a9560d4f9803c22566875b722bc27e275f311a6')
+ 'f3e725642c6b87d5a7fd25331a9560d4f9803c22566875b722bc27e275f311a6'
+ 'f216174d68ef7c26f29a58e409261c5b36af6593fe1778f6b2ad284095662b10')
prepare() {
cd "edb-debugger"
+ patch -p1 -i ../plugin_path.patch
}
build() {
cd "edb-debugger"
[ ! -d build ] && mkdir build
cd build
- cmake -DCMAKE_INSTALL_PREFIX="$pkgdir/usr/" ..
+ cmake -DCMAKE_INSTALL_PREFIX="$pkgdir/usr/" -DDEFAULT_PLUGIN_PATH="/usr/lib/edb/" ..
make
}