summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEddie.website2022-04-28 07:15:58 -0400
committerEddie.website2022-04-28 07:15:58 -0400
commitc350c03b5306271d5f0c379973851db5798c53e2 (patch)
tree00090e76a1e632bba0b91d00b923a953c7ec92b6 /PKGBUILD
parent2f355631b2115dae2e2c085697d04c95ded6df22 (diff)
downloadaur-c350c03b5306271d5f0c379973851db5798c53e2.tar.gz
2.21.6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 981053b4bb6d..da4aae335c14 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Based on work by Uncle Hunto <unclehunto äτ ÝãΗ00 Ð0τ ÇÖΜ> and Beini <bane aτ iki dot fi>
pkgname=eddie-ui-git
-pkgver=2.21.5
+pkgver=2.21.6
pkgrel=1
pkgdesc='Eddie - VPN tunnel - UI - beta'
arch=('i686' 'x86_64')
@@ -28,11 +28,18 @@ build() {
export TERM=xterm # Fix Mono bug "Magic number is wrong".
# Compile C# sources
+ # Forced target framework, otherwise throw
+ # warning : TargetFrameworkVersion 'v4.8' not supported by this toolset (ToolsVersion: 14.0).
+ # even on recent Manjaro (updated 2022-04-19)
+
+ # throw
+ # xbuild tool is deprecated and will be removed in future updates, use msbuild instead
+ # but never understand right dependencies that works on every Arch distro
cd "Eddie"
if [ "ui" = "cli" ]; then
- xbuild /verbosity:minimal /p:Configuration="Release" /p:Platform="$_pkgarch" src/eddie.linux.cli.sln
+ xbuild /verbosity:minimal /p:TargetFrameworkVersion="v4.5" /p:Configuration="Release" /p:Platform="$_pkgarch" src/eddie.linux.cli.sln
elif [ "ui" = "ui" ]; then
- xbuild /verbosity:minimal /p:Configuration="Release" /p:Platform="$_pkgarch" src/eddie2.linux.ui.sln
+ xbuild /verbosity:minimal /p:TargetFrameworkVersion="v4.5" /p:Configuration="Release" /p:Platform="$_pkgarch" src/eddie2.linux.ui.sln
fi
# Compile C sources (Tray)