summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLucas Malandrino2018-11-24 13:34:15 +0100
committerLucas Malandrino2018-11-24 13:34:15 +0100
commit18a666d28c424d782dbb92c6c3f4bdfa2246f624 (patch)
treec73b49cd48e12f7c227ae552203c382ee0763028 /PKGBUILD
parenta26e399c823b91bc6f3c864973f54b19e0ff649f (diff)
downloadaur-18a666d28c424d782dbb92c6c3f4bdfa2246f624.tar.gz
Fixed dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 25 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 45adb3f74457..26132227c6a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,41 +6,44 @@ pkgdesc="A science fiction desktop running everywhere. Awesome."
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
url='https://github.com/GitSquared/edex-ui'
license=('GPL3')
-depends=('c-ares' 'ffmpeg' 'gtk3' 'http-parser' 'libevent' 'libvpx' 'libxslt' 'libxss' 'minizip' 'nss' 're2' 'snappy' 'libnotify' 'libappindicator-gtk2' 'libappindicator-gtk3' 'libappindicator-sharp')
+depends=('gtk3'
+ 'gconf'
+ 'libxss'
+ 'nss')
makedepends=('npm')
provides=('edex-ui')
install="edex-ui.install"
source=("https://github.com/GitSquared/${pkgname}/archive/v${pkgver}.tar.gz"
- "package.json.patch")
+ "package.json.patch")
sha256sums=('18840ed0b73806d70a9e33a9171f811245c692bba8c02aa44334c1ca5f9a14c7'
- '66752ffc06b44692892967689e320af41dcd1365cdfe578cddb3b6d1123888f2')
+ '66752ffc06b44692892967689e320af41dcd1365cdfe578cddb3b6d1123888f2')
prepare() {
- # Temp fix for the missing mail field that causes electron-builder to fail
- patch -p1 -i "${srcdir}/package.json.patch" "${srcdir}/${pkgname}-${pkgver}/src/package.json"
+ # Temp fix for the missing mail field that causes electron-builder to fail
+ patch -p1 -i "${srcdir}/package.json.patch" "${srcdir}/${pkgname}-${pkgver}/src/package.json"
}
build() {
- cd "${pkgname}-${pkgver}"
+ cd "${pkgname}-${pkgver}"
- npm install
+ npm install
- # Build tarball with electron-builder
- npm run prebuild-linux
- ${srcdir}/${pkgname}-${pkgver}/node_modules/.bin/electron-builder -l pacman -p never
- npm run postbuild-linux
+ # Build tarball with electron-builder
+ npm run prebuild-linux
+ ${srcdir}/${pkgname}-${pkgver}/node_modules/.bin/electron-builder -l pacman -p never
+ npm run postbuild-linux
}
package() {
- cd "${pkgname}-${pkgver}"
-
- # Extract the package made by electron-builder
- # It's not pretty but blame electron
- tar xf ./dist/eDEX-UI-linux.pacman -C "${pkgdir}"
- cd "${pkgdir}"
-
- # Garbage madeby electron-builder
- rm -f "${pkgdir}/.INSTALL" "${pkgdir}/.MTREE" "${pkgdir}/.PKGINFO"
-
- chmod 755 "${pkgdir}/opt/eDEX-UI/edex-ui"
+ cd "${pkgname}-${pkgver}"
+
+ # Extract the package made by electron-builder
+ # It's not pretty but blame electron
+ tar xf ./dist/eDEX-UI-linux.pacman -C "${pkgdir}"
+ cd "${pkgdir}"
+
+ # Garbage madeby electron-builder
+ rm -f "${pkgdir}/.INSTALL" "${pkgdir}/.MTREE" "${pkgdir}/.PKGINFO"
+
+ chmod 755 "${pkgdir}/opt/eDEX-UI/edex-ui"
}