summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Blakeney2021-01-28 16:41:10 +1000
committerMark Blakeney2021-01-28 16:41:10 +1000
commit93ef60e715f4439d0c7b383c1bc436af41b0a619 (patch)
tree99756cc9ecb0aa353f7b63e62fc4e868a2ddb31a /PKGBUILD
parent272246ff0d4d32c418cabd08edcbd0d8bb2cf913 (diff)
downloadaur-93ef60e715f4439d0c7b383c1bc436af41b0a619.tar.gz
Fix up the pip build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a7b9b29234dc..5faede6a0ac6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: mark.blakeney at bullet-systems dot net
pkgname=edir
pkgver=2.7.3
-pkgrel=1
+pkgrel=2
pkgdesc="Program to rename and remove files and directories using your editor"
url="https://github.com/bulletmark/$pkgname"
license=("GPL3")
@@ -24,12 +24,14 @@ package() {
--no-warn-script-location \
--no-cache-dir \
--no-compile \
+ --progress-bar=off \
.
local pdir=$(python -c "import site; print(site.getsitepackages()[0])")
- local _pkgname=${pkgname//-/_}
+ local _pkgname="${pkgname//-/_}"
cd "$pkgdir/$pdir"
rm -f $_pkgname-*.dist-info/direct_url.json
+ sed -i "/\/direct_url.json,/d" $_pkgname-*.dist-info/RECORD
python -O -m compileall -q .
}