summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVictor2015-06-08 20:08:33 +0200
committerVictor2015-06-08 20:08:33 +0200
commit8134a4b809c901e7693f2ce876d4ba0a479e3c58 (patch)
tree44f8d4e687d7ec19ed9fc2501ad8f9859718bdf3 /PKGBUILD
downloadaur-8134a4b809c901e7693f2ce876d4ba0a479e3c58.tar.gz
Migrated from AUR 3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..634f0aaa3fcc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Mantainer: Victor <vicgua@outlook.com>
+
+pkgname=edis
+pkgver=2.0
+pkgrel=1
+pkgdesc="a simple cross-platform IDE for C"
+arch=('any')
+url="http://centaurialpha.github.io/edis"
+license=('GPLv3')
+depends=('python' 'python-pyqt4' 'python-qscintilla')
+makedepends=()
+optdepends=('ctags: symbol tree support'
+ 'cppcheck: static code analysis')
+conflicts=(edis-git edis-c edis-c-git)
+replaces=(edis-c)
+install=$pkgname.install
+source=("https://github.com/centaurialpha/$pkgname/archive/v${pkgver}.tar.gz"
+ "$pkgname.png"
+ "$pkgname.desktop")
+md5sums=('44c6f647a2812d4128ed533284a41318'
+ 'b62bba84e3be425a165f78f4261de1c7'
+ '4657b48c3efce21a9e5f8804d4892431')
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+
+ python setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 "edis.desktop" "$pkgdir/usr/share/applications/edis.desktop"
+}