summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Arndt2018-01-21 12:25:17 +0100
committerChristopher Arndt2018-01-21 12:25:17 +0100
commit061d22a7e71fc074a0173017266af46faa207781 (patch)
treec038159818258dcb58056439f3d1f2193709bb79 /PKGBUILD
parentf5dcee552492e2fafd1a936d01bde351a7c9c0b8 (diff)
downloadaur-061d22a7e71fc074a0173017266af46faa207781.tar.gz
Better source URL; Add provides and conflicts
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1f5e34c05a7f..decee12c8c49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,28 @@
# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
_pkgname=edisyn
+_githash="aa653caa498f8cc9bf582cf77279e2568023ad41"
pkgname="${_pkgname}-bin"
pkgver=13
-pkgrel=1
+pkgrel=2
pkgdesc="A cross-platform synthesizer patch editor library"
arch=('i686' 'x86_64')
url="https://github.com/eclab/edisyn/"
license=('Apache')
depends=('java-runtime=7')
-#provides=("${_pkgname}")
-#conflicts=("${_pkgname}")
-source=("${_pkgname}::git://github.com/eclab/${_pkgname}.git#commit=a436731d3eb980399efdd0b59d9d10d5e1b6aee6"
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("https://github.com/eclab/edisyn/raw/${_githash}/jar/edisyn.jar"
"${_pkgname}.desktop"
"${_pkgname}.sh")
-md5sums=('SKIP'
+md5sums=('c4ef78b127533bbf40325bda77f657f1'
'5022b2d274e99ca6704f4dd69e17a1cb'
'a6f1544c7b08354593f2c5b91258d88c')
package() {
cd "${srcdir}/${_pkgname}"
- install -Dm644 "jar/${_pkgname}.jar" \
+ install -Dm644 "${srcdir}/${_pkgname}.jar" \
"${pkgdir}/usr/share/${_pkgname}/${_pkgname}.jar"
install -Dm755 "${srcdir}/${_pkgname}.sh" \
"${pkgdir}/usr/bin/${_pkgname}"