summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIsmaël Bouya2021-01-22 08:47:22 +0100
committerIsmaël Bouya2021-01-22 08:47:22 +0100
commit17f3447c4314ea976ff5cbaf2c0fd4cd42063bed (patch)
tree464403d9f8bbad554e24d92f674693474ec2f79e /PKGBUILD
parentb9aebd1750d435e8588fd602d746ac2374aba471 (diff)
downloadaur-editline.tar.gz
Upgrade editline
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5865c5fd06d1..75e408e80442 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,16 @@
# Maintainer : Immae <ismael.bouya@normalesup.org>
+# Contributor: George Rawlinson <george@rawlinson.net.nz>
pkgname=editline
-pkgver=1.16.1
+pkgver=1.17.1
pkgrel=1
pkgdesc="A readline() replacement for UNIX without termcap (ncurses)"
arch=('x86_64')
url="http://troglobit.com/editline.html"
license=('BSD')
-source=("https://github.com/troglobit/${pkgname}/archive/${pkgver}.tar.gz")
-sha512sums=('32c8362cd553ff616ecbb259705d6ed13a48f5bae0616c9770d9c254e07723bbd957de8ad0643d0652ec73e8e99e8c45e7f060461ba316b0eb30d911d772b029')
-
+depends=('glibc')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/troglobit/$pkgname/archive/$pkgver.tar.gz")
+sha512sums=('6fd8951a490e0a3f30bb20d775036f622e583042d6dc315d657bb9fdad76b3f4e219290f24ab497209d6143a56dd1d227152ba0c40e7912b8a443ab50f9b05dd')
build () {
cd "$pkgname-$pkgver"
@@ -24,4 +25,6 @@ package() {
cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
mv $pkgdir/usr/share/man/man3/editline.3 $pkgdir/usr/share/man/man3/editline-troglobit.3
+
+ install -Dm0644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
}