summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12017-03-19 15:00:54 +0800
committerChocobo12017-03-19 15:54:56 +0800
commitda75ae166108fddd2be3762e387763a7ef27ea60 (patch)
tree954ab13a29036b8d5e50fcd60f6cca56fb65fa9c /PKGBUILD
parent2927dd5b1b439e1574c8bd41cab68ea67ac0ccd4 (diff)
downloadaur-da75ae166108fddd2be3762e387763a7ef27ea60.tar.gz
Change maintainer
Add double quotes Remove comments Change indent size
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 12 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bc03b39d1503..d5481e52c098 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,27 @@
-# Maintainer: Tom Richards <tom@tomrichards.net>
-# https://github.com/t-richards/aur-editorconfig-gedit
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+# Former maintainer: Tom Richards <tom@tomrichards.net> https://github.com/t-richards/aur-editorconfig-gedit
+
pkgname=editorconfig-gedit
pkgver=0.5.3
pkgrel=1
pkgdesc="EditorConfig plugin for gedit"
arch=('any')
-url="http://editorconfig.org"
+url="http://editorconfig.org/"
license=('BSD')
depends=('gedit' 'python-editorconfig')
-
source=("https://github.com/editorconfig/${pkgname}/archive/v${pkgver}.tar.gz")
sha256sums=('d6c88a400bfbab36355ab6674db65c0d4997c970fc58a08752c1b331bea625e3')
package() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname-$pkgver"
+
+ _installdir="$pkgdir/usr/lib/gedit/plugins"
+ mkdir -p "$_installdir"
- # Plugin
- _installdir="$pkgdir/usr/lib/gedit/plugins"
- mkdir -p "$_installdir"
- cp -r editorconfig_plugin/ "$_installdir"
- cp editorconfig.plugin "$_installdir"
- cp editorconfig_gedit3.py "$_installdir"
- sed -i 's/python/python3/' "$_installdir/editorconfig.plugin"
+ cp -r "editorconfig_plugin/" "$_installdir"
+ cp "editorconfig.plugin" "$_installdir"
+ cp "editorconfig_gedit3.py" "$_installdir"
- # License
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}