summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwillemw122018-10-05 12:42:44 +0200
committerwillemw122018-10-05 12:52:10 +0200
commitcd1b7c745349c256fdc1178e587ab288a0df4b7e (patch)
tree341dea106bd2494c096bdf514ed04c32d889c059 /PKGBUILD
parented6843a939abbe1ca15e54093ec472eb53d4f970 (diff)
downloadaur-cd1b7c745349c256fdc1178e587ab288a0df4b7e.tar.gz
Remove installpri patch. Update url=, source= and arch=
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 5 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c55cbb2cbd0d..c3a1008f3c51 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,37 +3,33 @@
_pkgname=edyuk
pkgname=$_pkgname-svn
-pkgver=r1053
-pkgrel=3
+pkgver=r1053
+pkgrel=4
pkgdesc="Fully-featured Qt4 IDE"
-arch=('i686' 'x86_64')
-url="http://www.edyuk.org"
+arch=('x86_64')
+url="https://sourceforge.net/projects/edyuk/"
license=('GPL3')
depends=('qt4')
makedepends=('subversion')
provides=($_pkgname)
conflicts=($_pkgname)
-install=$pkgname.install
-source=($pkgname::svn+http://edyuk.svn.sf.net/svnroot/edyuk/trunk)
+source=($pkgname::svn+https://svn.code.sf.net/p/edyuk/code/trunk)
md5sums=('SKIP')
pkgver() {
cd $pkgname
-
local ver="$(svnversion)"
printf "r%s" "${ver//[[:alpha:]]}"
}
prepare() {
cd $pkgname
-
sed -i 's|return m_handle ? m_handle->document() : false|return m_handle ? m_handle->document() != 0 : false|' \
3rdparty/qcodeedit2/lib/document/qdocumentline.cpp
}
build() {
cd $pkgname
-
qmake-qt4
make