summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKeshav Amburay2012-01-03 20:40:46 +0530
committerKeshav Amburay2012-01-03 20:40:46 +0530
commitaa7a3bee78f6bc2308f8edd891006d0348ec2b56 (patch)
tree9a9c3fbd8ffabd0a4fec7a2481052062bc8aa551 /PKGBUILD
parenta7b283e39bf51b438f077ae182298c724d82db04 (diff)
downloadaur-aa7a3bee78f6bc2308f8edd891006d0348ec2b56.tar.gz
M
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4be09dd7cfeb..239552003fb3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,23 +21,26 @@ sha256sums=('5306a6f952d17215b129392953ae6551df0e4cf1960a959ab98c60f27fab9b90')
_gitroot="http://linux.dell.com/git/${_pkgname}.git"
_gitname="${_pkgname}"
-
+_gitbranch="master"
_update_git() {
- cd "${srcdir}"
+ cd "${srcdir}/"
+
msg "Connecting to GIT server...."
- if [ -d "${srcdir}/${_gitname}/" ]
+ if [[ -d "${srcdir}/${_gitname}/" ]]
then
cd "${srcdir}/${_gitname}/"
git reset --hard
git fetch
- git checkout master
- git merge remotes/origin/master
+ git checkout "${_gitbranch}"
+ git merge "remotes/origin/${_gitbranch}"
msg "The local GIT repo has been updated."
else
git clone "${_gitroot}" "${_gitname}"
+ cd "${srcdir}/${_gitname}/"
+ git checkout "${_gitbranch}"
msg "GIT checkout done or server timeout"
fi
@@ -45,7 +48,6 @@ _update_git() {
}
-
build() {
_update_git