summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2021-10-14 15:51:38 -0300
committerDaniel Bermond2021-10-14 15:51:38 -0300
commit3bfed2ae965581ae0dc42871642e60f0de8dc929 (patch)
tree140a75675ee541710b4764c5b6de87b57aed70d2 /PKGBUILD
parentb1eb20788e14fa65f4a2b359a5e2b9a4a0b92a21 (diff)
downloadaur-3bfed2ae965581ae0dc42871642e60f0de8dc929.tar.gz
Add nvidia gbm egl config file
gbm egl is supported by the proprietary nvidia driver since its version 495.29.05.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5cec650ad1ce..5f9be59a309f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=egl-wayland-git
pkgver=1.1.8.r0.gce4c963
-pkgrel=1
+pkgrel=2
pkgdesc='EGLStream-based Wayland external platform (git version)'
arch=('x86_64')
url='https://github.com/NVIDIA/egl-wayland/'
@@ -13,9 +13,11 @@ makedepends=('git' 'meson' 'eglexternalplatform' 'libglvnd>=1.3.4' 'wayland-prot
provides=('egl-wayland' 'libnvidia-egl-wayland.so')
conflicts=('egl-wayland')
source=('git+https://github.com/NVIDIA/egl-wayland.git'
- '10_nvidia_wayland.json')
+ '10_nvidia_wayland.json'
+ '15_nvidia_gbm.json')
sha256sums=('SKIP'
- '5cccf1905a266e8e34d5ad4aad4be85390e60b1a0850a29dd9d64adc641de412')
+ '5cccf1905a266e8e34d5ad4aad4be85390e60b1a0850a29dd9d64adc641de412'
+ 'be0e01a28300d80ea9a326718d4bdc45eb1ec5d80482a8f6e69e9e1594a5f196')
pkgver() {
git -C egl-wayland describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
@@ -34,5 +36,6 @@ package() {
DESTDIR="$pkgdir" ninja install -C build
cp -dr --no-preserve='ownership' egl-wayland/include "${pkgdir}/usr"
install -D -m644 10_nvidia_wayland.json -t "${pkgdir}/usr/share/egl/egl_external_platform.d"
+ install -D -m644 15_nvidia_gbm.json -t "${pkgdir}/usr/share/egl/egl_external_platform.d"
install -D -m644 egl-wayland/COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}