summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael2022-09-12 01:29:09 +0200
committerMichael2022-09-12 01:29:09 +0200
commit3858ac8664bd036a882d356134e5b5813373237e (patch)
tree0342d728f8e25fb4223524a3965fe69014db3c79 /PKGBUILD
parent0549cf9368d27944716a722ef69c6b79090aec6e (diff)
downloadaur-3858ac8664bd036a882d356134e5b5813373237e.tar.gz
update aur to fetch latest main branch again
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 22 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 23daae2f9ccf..2743cde80cd1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,43 @@
# Maintainer: hertg <aur@her.tg>
_pkgname=egpu-switcher
pkgname=$_pkgname-git
-pkgver=0.17.0.r2.ge9b9479
+pkgver=v0.18.0.rc.5.r0.g04b64c8
pkgrel=1
epoch=0
pkgdesc="Distribution agnostic script that works with NVIDIA and AMD cards."
arch=('any')
url="https://github.com/hertg/egpu-switcher"
license=('GPL')
-depends=('pciutils>=3.3.0' 'bash>=4.0')
-makedepends=('git')
+depends=()
+makedepends=('git' 'go')
provides=($_pkgname)
conflicts=($_pkgname)
install=${pkgname}.install
-source=("${pkgname}::git+https://github.com/hertg/egpu-switcher.git#branch=legacy")
+source=("${pkgname}::git+https://github.com/hertg/egpu-switcher.git")
md5sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname}"
+ cd "$srcdir/$pkgname"
printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g')"
}
+# check() {
+# cd "$srcdir/$pkgname"
+# make test
+# }
+
+build() {
+ cd "$srcdir/$pkgname"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export ORIGIN="aur"
+ make build -s
+}
+
package() {
- cd "$srcdir/${pkgname}"
- make DESTDIR="$pkgdir/" install
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir/" install -s
}