summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohannes Dewender2017-05-30 01:43:20 +0200
committerJohannes Dewender2017-05-30 01:43:20 +0200
commit0f3bea0d933e925f7cb57bbc27ee1fa35a2c00c4 (patch)
tree3b47d5a116fe3e3737e0269ccaaab221d434747b /PKGBUILD
parent3746ee99a6a3f106a082af6991de94d5443cbdd6 (diff)
downloadaur-0f3bea0d933e925f7cb57bbc27ee1fa35a2c00c4.tar.gz
fix binary symlinks
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 57e8886e18ac..7fd693e0494d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=elasticdump2
_pkgname=elasticdump
pkgver=2.4.2
-pkgrel=1
+pkgrel=2
pkgdesc="Import and export tools for Elasticsearch < 5"
arch=(any)
url="https://www.npmjs.com/package/elasticdump"
@@ -20,6 +20,9 @@ package() {
rm -r "$pkgdir/usr/etc"
mv "$pkgdir/usr/lib/node_modules/$_pkgname" "$pkgdir/usr/lib/node_modules/$pkgname"
- mv "$pkgdir/usr/bin/$_pkgname" "$pkgdir/usr/bin/$pkgname"
- mv "$pkgdir/usr/bin/multi$_pkgname" "$pkgdir/usr/bin/multi$pkgname"
+ rm "$pkgdir/usr/bin/$_pkgname"
+ rm "$pkgdir/usr/bin/multi$_pkgname"
+ cd "$pkgdir/usr/bin"
+ ln -s "../lib/node_modules/$pkgname/bin/$_pkgname" $pkgname
+ ln -s "../lib/node_modules/$pkgname/bin/multi$_pkgname" multi$pkgname
}