summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBoris Momčilović2022-07-18 16:16:37 +0200
committerBoris Momčilović2022-07-18 16:16:37 +0200
commitb8136796cdc850424ea0e5875b791c1e5201862d (patch)
tree98ead975cd018a54fe31a778daabc161c600d9b0 /PKGBUILD
parent77d29d25b250790320f837cac2b2f05d7fa61b05 (diff)
downloadaur-b8136796cdc850424ea0e5875b791c1e5201862d.tar.gz
JDK
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 87c4f3688c61..e81c82230244 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ pkgdesc="Distributed RESTful search engine built on top of Lucene"
arch=('x86_64')
url="https://www.elastic.co/products/elasticsearch"
license=('custom:SSPL+Elastic-2.0')
-depends=('java-environment=17' 'systemd' 'libxml2')
+depends=('java-environment>=17' 'systemd' 'libxml2')
makedepends=('java-environment>=17')
source=(
$pkgname-$pkgver.tar.gz::"https://github.com/elastic/elasticsearch/archive/v${pkgver}.tar.gz"
@@ -50,7 +50,7 @@ prepare() {
build() {
cd $pkgname-$pkgver
- export PATH=/usr/lib/jvm/java-17-openjdk/bin:$PATH
+ export PATH=/usr/lib/jvm/`archlinux-java get`/bin:$PATH
export GRADLE_OPTS="-Dbuild.snapshot=false -Dlicense.key=x-pack/plugin/core/snapshot.key"
./gradlew :modules:systemd:assemble
./gradlew :distribution:archives:linux-tar:assemble