summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGordian Edenhofer2016-02-02 21:41:25 +0100
committerGordian Edenhofer2016-02-02 23:20:07 +0100
commit5e69e2d349ab41abf0ecfdc682a6980c1d89d33d (patch)
tree175a5481fa2fb5596f3d0a9f2c38c91f43686556 /PKGBUILD
parent1abdf7ffdab930d288b7c38409ad56a269ab918b (diff)
downloadaur-5e69e2d349ab41abf0ecfdc682a6980c1d89d33d.tar.gz
Upgpkg: 2.2.4-1
Completely redesign the package on top of the patched debian source package. Therefore removing the need for manual patching. Mimic the Makefile install operation since it broken in a lot of ways. Add glibc and bash to the dependency array. Update the URL to the debian package inspection URL.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD51
1 files changed, 21 insertions, 30 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 700b58cb7446..d025ef879a03 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,31 @@
+# Maintainer: Gordian Edenhofer <gordian.edenhofer[at]yahoo[dot]de>
# Contributor: Jonathan Liu <net147@gmail.com>
+
pkgname=electricfence
-pkgver=2.2.2
-pkgrel=3
-pkgdesc="Debugging malloc() that uses the VM hardware to detect buffer overruns"
+pkgver=2.2.4
+pkgrel=1
+pkgdesc="A malloc(3) debugger that uses virtual memory hardware to detect illegal memory accesses."
arch=('i686' 'x86_64')
-url="http://perens.com/FreeSoftware/ElectricFence/"
license=('GPL2')
-source=("http://dl.packetstormsecurity.net/programming-tutorials/ElectricFence-${pkgver}.tar.gz"
- "ef.sh.patch"
- "efence.c.patch"
- "eftest.c.patch"
- "page.c.patch"
- "print.c.patch")
-md5sums=('56a3cbfdbf65f916988787c789c63e80'
- '3d5905c3cc9c52f09b6a387520a0d86c'
- '67023a6cdcae4058e698089b041d00a8'
- '3aad193fdc0b282d5d5fb05bb06ba4f9'
- '4b5292775e9588b21ccf867f0160a34d'
- '5026c7863d3b980ff093cb2d22c2d303')
+url="https://packages.debian.org/sid/electric-fence"
+depends=('glibc' 'bash')
+source+=("http://archive.ubuntu.com/ubuntu/pool/universe/e/electric-fence/electric-fence_${pkgver}.tar.gz"
+ "ef.sh")
+md5sums=('78197d625452a9bc2d171e47bce0ddff'
+ '215c183e71fa6f8d40cbd2fe65c860c9')
build() {
- cd "${srcdir}/ElectricFence-${pkgver}"
- patch -Np0 -i "$startdir/src/ef.sh.patch"
- patch -Np0 -i "$startdir/src/efence.c.patch"
- patch -Np0 -i "$startdir/src/eftest.c.patch"
- patch -Np0 -i "$startdir/src/page.c.patch"
- patch -Np0 -i "$startdir/src/print.c.patch"
- make
+ make -C "${srcdir}/electric-fence-2.2.3"
}
package() {
- cd "${srcdir}/ElectricFence-${pkgver}"
- install -d -m 755 "${pkgdir}/usr/bin"
- install -d -m 755 "${pkgdir}/usr/lib"
- install -d -m 755 "${pkgdir}/usr/man/man3"
- make install prefix="${pkgdir}/usr" install
-}
+ cd "${srcdir}/electric-fence-2.2.3"
-# vim:set ts=2 sw=2 et:
+ # Mimic the Makefile since it is pretty broken
+ install -D -m755 ../ef.sh "${pkgdir}"/usr/bin/ef
+ install -D -m644 libefence.a "${pkgdir}"/usr/lib/libefence.a
+ install -D -m755 libefence.so.0.0 "${pkgdir}"/usr/lib/libefence.so.0.0
+ ln -s libefence.so.0.0 "${pkgdir}"/usr/lib/libefence.so.0
+ ln -s libefence.so.0.0 "${pkgdir}"/usr/lib/libefence.so
+ install -D -m644 libefence.3 "${pkgdir}"/usr/man/man3/libefence.3
+}