summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortensor52022-01-28 09:10:47 +0000
committersvntogit2022-01-28 09:10:47 +0000
commit5aa5438f1688b7c087f0a42e04de96f87bb47fe0 (patch)
tree87bf7c34aa762f60422c602067c1a9f4b27e38ee /PKGBUILD
parenta9723bcdb7221e2e04077cc18a81c838a6540d5e (diff)
downloadaur-5aa5438f1688b7c087f0a42e04de96f87bb47fe0.tar.gz
upgpkg: electron14 14.2.5-1
git-svn-id: file:///srv/repos/svn-community/svn@1118170 9fca08f4-af9d-4005-b8df-a31f2cc04f65
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3ccf4d21e8db..ccf4a5f34451 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Nicola Squartini <tensor5@gmail.com>
_use_suffix=1
-pkgver=14.2.4
-_commit=771261f6b7af5f7618d52f7607a76a1010e64c42
+pkgver=14.2.5
+_commit=f6798c5e994f9e1d7f88812ef6e5877e85b9c0eb
_chromiumver=93.0.4577.82
_gcc_patchset=6
# shellcheck disable=SC2034
@@ -42,6 +42,8 @@ if [[ ${_use_suffix} == 0 ]]; then
provides=("electron${_major_ver}")
fi
# shellcheck disable=SC2034
+options=('!lto') # Electron adds its own flags for ThinLTO
+# shellcheck disable=SC2034
source=('git+https://github.com/electron/electron.git'
'git+https://chromium.googlesource.com/chromium/tools/depot_tools.git#branch=main'
"https://github.com/stha09/chromium-patches/releases/download/chromium-${_chromiumver%%.*}-patchset-${_gcc_patchset}/chromium-${_chromiumver%%.*}-patchset-${_gcc_patchset}.tar.xz"
@@ -227,6 +229,11 @@ build() {
CFLAGS="${CFLAGS/-fexceptions/}"
CXXFLAGS="${CXXFLAGS/-fexceptions/}"
+ # This appears to cause random segfaults when combined with ThinLTO
+ # https://bugs.archlinux.org/task/73518
+ CFLAGS=${CFLAGS/-fstack-clash-protection}
+ CXXFLAGS=${CXXFLAGS/-fstack-clash-protection}
+
# Do not warn about unknown warning options
CFLAGS+=' -Wno-unknown-warning-option'
CXXFLAGS+=' -Wno-unknown-warning-option'