summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsl1pkn072015-09-30 22:47:14 +0200
committersl1pkn072015-09-30 22:47:14 +0200
commit418fbe9215f913fe7d9616f504acf527241e83c5 (patch)
tree69f4dc4a8ec77fdd9d668ff2ca636de947a9f40a /PKGBUILD
parentc08bb06ea6ebc25e33cc3af94e85a27d10882bbf (diff)
downloadaur-418fbe9215f913fe7d9616f504acf527241e83c5.tar.gz
Tweak PKGBUILD (add swig to makedepends=())
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 16 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2984d41c4558..449f6392ff07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,26 @@
# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
pkgname=elektra-git
-pkgver=0.8.13.36.g618d73f
+pkgver=0.8.13.59.gea3d489
pkgrel=1
pkgdesc="A universal hierarchical configuration store. (GIT version)"
arch=('i686' 'x86_64')
url='https://github.com/ElektraInitiative/libelektra'
license=('BSD')
depends=('qt5-declarative' 'yajl' 'augeas' 'discount')
-makedepends=('git' 'cmake' 'boost' 'docbook-xsl' 'texlive-latexextra' 'texlive-fontsextra' 'tcl' 'python2-cheetah' 'lua52' 'python' 'python2' 'gobject-introspection' 'ruby-ronn')
+makedepends=('git'
+ 'cmake'
+ 'boost'
+ 'docbook-xsl'
+ 'texlive-latexextra'
+ 'texlive-fontsextra'
+ 'tcl'
+ 'python2-cheetah'
+ 'lua52'
+ 'python'
+ 'gobject-introspection'
+ 'ruby-ronn'
+ 'swig')
optdepends=('lua52: Lua bindings'
'python: Python 3 bindings'
'python2: Python 2 bindings')
@@ -24,6 +36,8 @@ pkgver() {
prepare(){
mkdir -p build
+
+ export JAVA_HOME="/usr/lib/jvm/default"
}
build() {