summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTomoghno2021-08-28 12:16:26 +0530
committerTomoghno2021-08-28 12:16:26 +0530
commitfe838a6236e8f7bd89171d268e8f8c0f1454b04b (patch)
tree20368cf727659e9243c2c852ab65f61f01585eca /PKGBUILD
downloadaur-fe838a6236e8f7bd89171d268e8f8c0f1454b04b.tar.gz
Initial Release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d51849024de0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Tomoghno Sen <tomoghno at outlook dot com>
+
+pkgname=elementary-mixer
+pkgver=0.1.3
+pkgrel=1
+pkgdesc="Change the volume of apps"
+arch=('x86_64')
+url="https://appcenter.elementary.io/com.github.childishgiant.mixer/"
+license=('GPL3')
+depends=('granite' 'libhandy')
+makedepends=('meson' 'vala')
+provides=('com.github.childishgiant.mixer')
+conflicts=('com.github.childishgiant.mixer')
+source=("mixer-$pkgver.tar.gz::https://github.com/ChildishGiant/mixer/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('4131df912f141b60911e6f571bab6871c4ba9b49003c0532a77a57de9a818ed2')
+
+build() {
+ arch-meson mixer-$pkgver build
+ meson compile -C build
+}
+
+# No tests defined
+#check() {
+# meson test -C build --print-errorlogs
+#}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}