summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12023-04-08 03:34:27 +0800
committerChocobo12023-04-08 03:34:27 +0800
commit6c052fab8e4b5c05e8e13586ee02a9012ff5edc7 (patch)
treee7b810ba2dd4b8b5239c37036fd3579c96c268b8 /PKGBUILD
parent4dc2b9db4e471752d5c347cb3e5f2e585961ddaa (diff)
downloadaur-elfutils-git.tar.gz
upgpkg: elfutils-git 0.189.r14.g6e971808-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8a4fec959f71..0a1a039da1fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=elfutils-git
-pkgver=0.170.r8.g760925bc
+pkgver=0.189.r14.g6e971808
pkgrel=1
pkgdesc="Utilities and libraries to handle ELF object files and DWARF debugging information"
arch=('i686' 'x86_64')
url="https://sourceware.org/elfutils/"
license=('GPL3')
-depends=('glibc' 'bzip2' 'xz' 'zlib' 'sh')
+depends=('glibc' 'bzip2' 'sh' 'xz' 'zlib')
makedepends=('git')
-provides=('elfutils' 'libelf')
+provides=("elfutils=$pkgver" 'libelf')
conflicts=('elfutils' 'libelf')
options=('staticlibs')
source=("git+https://sourceware.org/git/elfutils.git")
@@ -27,7 +27,10 @@ build() {
autoreconf -fi
CFLAGS+=" -g" # required for test-suite success
- ./configure --prefix="/usr" --program-prefix="eu-" --enable-maintainer-mode
+ ./configure \
+ --prefix="/usr" \
+ --program-prefix="eu-" \
+ --enable-maintainer-mode
make
}