summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonas Schürmann2018-09-04 21:09:47 +0200
committerJonas Schürmann2018-09-04 21:09:47 +0200
commitd15fd4ff100f209ad614e92e037bc6a7c36e6e51 (patch)
tree3f7870427b8dab6a5e4da4e0cb096e762e4d98a1 /PKGBUILD
downloadaur-d15fd4ff100f209ad614e92e037bc6a7c36e6e51.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..930f5ec01e1f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Jonas Schürmann <jonasschuermann@aol.de>
+# Contributor: Matt Bray <mattjbray@gmail.com>
+_elm_version=0.19
+pkgname=elm-format-bin
+pkgver=0.8.0
+pkgrel=1
+epoch=
+pkgdesc="Format Elm source code according to a standard set of rules based on the official Elm Style Guide."
+arch=('i686' 'x86_64')
+url="https://github.com/avh4/elm-format"
+license=('BSD')
+groups=()
+depends=()
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=(elm-format)
+conflicts=(elm-format-0.16-bin elm-format-0.17-bin elm-format-0.18-bin elm-format-0.18-exp-bin)
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/avh4/elm-format/releases/download/${pkgver}/elm-format-${_elm_version}-${pkgver}-linux-x64.tgz"
+ "https://github.com/avh4/elm-format/releases/download/${pkgver}/elm-format-${_elm_version}-${pkgver}-linux-x64.tgz.asc"
+ "LICENSE-${pkgver}::https://raw.githubusercontent.com/avh4/elm-format/${pkgver}/LICENSE")
+noextract=()
+md5sums=('ecef0d7d0d66c7b35f9dd1c1ef5f9a52'
+ 'SKIP'
+ 'e3bb965f28c7631a1bac6d8611a1db7d')
+validpgpkeys=('C3B74EE9EBC8412DFEE1FECE11357FB6FDD7BEC0')
+
+package() {
+ install -Dm755 "elm-format" "$pkgdir/usr/bin/elm-format"
+ install -Dm644 "LICENSE-${pkgver}" "${pkgdir}/usr/share/licenses/elm-format/LICENSE"
+}