summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLukas Werling2016-06-12 16:06:11 +0200
committerLukas Werling2016-06-12 16:06:11 +0200
commit8710e7566a2b089b3f89f149ef0aa1e17212f30c (patch)
tree753da22c6c294f2a5607f808cebaeb9687913d74 /PKGBUILD
parent562b46f5683c4d8657720ed07cc84e4f88870ccb (diff)
downloadaur-8710e7566a2b089b3f89f149ef0aa1e17212f30c.tar.gz
Fix build with GHC 8
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bad1a019b05e..1fecc6a4ca2d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Lukas Werling <lukas.werling@gmail.com>
pkgname=elm-platform
pkgver=0.17
-pkgrel=2
+pkgrel=3
pkgdesc="Bundle of all core development tools for the Elm language."
arch=('i686' 'x86_64')
url="http://elm-lang.org"
@@ -22,6 +22,13 @@ sha256sums=('1dc1a5fa5cd09936dee8fbba1f0197527bb988b2cc045919ce6bbb9a6706e122'
'f03b07018eb3c3c4cc4c8f311b8f33572371e20ae51f4eb4fb5247d98e5f51dc'
'e4c7fa471cfc1b7fc37e38a4cdaffe90b3f06c5f52fc20e6e8167eb1ef8defe6')
+prepare() {
+ cd "$srcdir"
+
+ # This is currently necessary to build with GHC 8, see https://github.com/elm-lang/elm-compiler/issues/1397
+ echo 'allow-newer: aeson,base,HTTP,time,transformers' > cabal.config
+}
+
# This does not actually use the build script in the elm-lang/elm-platform
# repository, but the commands below are taken from there.
build() {