summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortequa2015-10-25 12:20:22 +0100
committertequa2015-10-25 12:20:22 +0100
commitf3be35c29392a5dc9780ed883caea2dd05c1092d (patch)
treeafabbc7db37664260a8fa34acb575705e3dc8660 /PKGBUILD
downloadaur-f3be35c29392a5dc9780ed883caea2dd05c1092d.tar.gz
initial commit eltclsh 1.15
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf19c1419a9d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: tequa
+pkgname=eltclsh
+pkgver=1.15
+pkgrel=1
+epoch=
+pkgdesc="eltclsh (editline tcl shell) is an interactive shell for the TCL programming language"
+arch=('i686' 'x86_64' 'armv7h')
+url="http://homepages.laas.fr/mallet/soft/shell/eltclsh"
+license=('BSD')
+groups=()
+depends=('tcl' 'tk' 'libedit')
+makedepends=('make' 'gcc')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("http://distfiles.openrobots.org/eltclsh/$pkgname-$pkgver.tar.gz")
+noextract=()
+md5sums=('17f1f16ac44dff76a451fe62d8f4f8fd')
+validpgpkeys=()
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}