summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2019-10-12 12:56:05 +0200
committerhaawda2019-10-12 12:56:05 +0200
commit6c24b24dc64a47b8152e85376df040ec3e7c3f89 (patch)
tree93b232a99782128ec1969794b019c70d84ab1c45 /PKGBUILD
downloadaur-6c24b24dc64a47b8152e85376df040ec3e7c3f89.tar.gz
initial upload
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2748af9dbe4b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: Alex Whitt <alex.joseph.whitt@gmail.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+_pkgsrcname=a.el
+_pkgmaintainer=plexus
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="Clojure Parser for Emacs Lisp"
+pkgname=emacs-a
+arch=('any')
+url="https://github.com/${_pkgmaintainer}/a.el"
+license=('GPL3')
+depends=('emacs')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/${_pkgmaintainer}/${_pkgsrcname}/archive/v${pkgver}.tar.gz")
+sha256sums=('2998451375103630ceac2e3b8adc4522855aa890874b632e586632434dbd66a1')
+
+build() {
+ cd ${_pkgsrcname}-${pkgver}
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd ${_pkgsrcname}-${pkgver}
+ install -d "${pkgdir}"/usr/share/emacs/site-lisp/
+ install -m644 *.el{c,} "${pkgdir}"/usr/share/emacs/site-lisp
+}