summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsballert2018-08-30 19:09:39 +0200
committersballert2018-08-30 19:09:39 +0200
commitd5413db8c0f19219de0a49b5c4b7485755cdfe28 (patch)
tree2edef39b1ec8d6b8a1abc1d219d47bcca0d3ffe3 /PKGBUILD
downloadaur-emacs-ace-window-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5ec8ae88bd14
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: sballert <sballert@posteo.de>
+
+pkgname=emacs-ace-window-git
+pkgver=r152.d93e16b
+pkgrel=1
+pkgdesc="Quickly switch windows in Emacs"
+url="https://github.com/abo-abo/ace-window"
+arch=('any')
+license=('GPL3')
+depends=('emacs' 'emacs-avy')
+makedepends=('git')
+provides=('emacs-ace-window')
+conflicts=('emacs-ace-window')
+source=("git+https://github.com/abo-abo/ace-window.git")
+sha256sums=('SKIP')
+_gitname="ace-window"
+
+pkgver() {
+ cd "$_gitname"
+ printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$_gitname"
+ make clean test compile
+}
+
+package() {
+ cd "$_gitname"
+ install -d "${pkgdir}/usr/share/emacs/site-lisp/ace-window"
+ install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/ace-window/"
+}