summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2018-07-21 20:10:09 +0200
committerhaawda2018-07-21 20:10:09 +0200
commit1eb9540ee8db65142fc344a0add6552f52a5c20c (patch)
treea80a85a02635fb63c2bc856d43adc8bf25d4e981 /PKGBUILD
parent4d2f6ade0a7a3e70d4bf05081d28cd3d4bb0a44a (diff)
downloadaur-1eb9540ee8db65142fc344a0add6552f52a5c20c.tar.gz
adopted
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 17 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f343606f191e..f1a0bfd7644d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,12 @@
-# $Id: PKGBUILD 59903 2011-12-02 11:18:13Z andrea $
-# Maintainer:
-# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
# Contributor: Cesar Romero <cesar.romero@gmail.com>
pkgname=emacs-color-theme
pkgver=6.6.0
-pkgrel=8
+pkgrel=9
arch=('any')
pkgdesc="Emacs color themes"
-url="https://gna.org/projects/color-theme"
+url="http://www.nongnu.org/color-theme/"
license=('GPL2')
depends=('emacs' 'xorg-fonts-100dpi')
makedepends=('emacs')
@@ -22,27 +20,29 @@ md5sums=('a4de73c236a6af11ab378bfe18dabcca'
'8b7ee1c4c6f80606f22c3de448ec92e8'
'25b92ea246716689502ebe050322a60a')
+prepare() {
+ cd color-theme-$pkgver
+ patch -p1 -i "$srcdir"/gnus-bug.diff
+ patch -p0 -i "$srcdir"/fix-build.patch
+}
+
build() {
- cd $srcdir/color-theme-$pkgver
-
- patch -p1 -i $srcdir/gnus-bug.diff
- patch -p0 -i $srcdir/fix-build.patch
-
+ cd color-theme-$pkgver
make
}
package() {
- cd $srcdir/color-theme-$pkgver
+ cd color-theme-$pkgver
install -Dm644 color-theme.el \
- $pkgdir/usr/share/emacs/site-lisp/color-theme.el
+ "$pkgdir"/usr/share/emacs/site-lisp/color-theme.el
install -Dm644 themes/color-theme-library.el \
- $pkgdir/usr/share/emacs/site-lisp/themes/color-theme-library.el
+ "$pkgdir"/usr/share/emacs/site-lisp/themes/color-theme-library.el
install -Dm644 themes/color-theme-example.el \
- $pkgdir/usr/share/emacs/site-lisp/themes/color-theme-example.el
+ "$pkgdir"/usr/share/emacs/site-lisp/themes/color-theme-example.el
install -Dm644 color-theme.elc \
- $pkgdir/usr/share/emacs/site-lisp/color-theme.elc
+ "$pkgdir"/usr/share/emacs/site-lisp/color-theme.elc
install -Dm644 themes/color-theme-library.elc \
- $pkgdir/usr/share/emacs/site-lisp/themes/color-theme-library.elc
+ "$pkgdir"/usr/share/emacs/site-lisp/themes/color-theme-library.elc
install -Dm644 themes/color-theme-example.elc \
- $pkgdir/usr/share/emacs/site-lisp/themes/color-theme-example.elc
+ "$pkgdir"/usr/share/emacs/site-lisp/themes/color-theme-example.elc
}