summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2019-03-11 17:21:28 +0100
committerhaawda2019-03-11 17:21:28 +0100
commite50adf93c953de119ab55e2bb0363579f7f4f92e (patch)
treefb546f9bb743eb36bf82d4fef36b684957017803 /PKGBUILD
parente5c0af68b4020a22fda464b00fd2646fe3c636c7 (diff)
downloadaur-e50adf93c953de119ab55e2bb0363579f7f4f92e.tar.gz
initial upload
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 14 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 215e46368a9f..95c6bc7dc5e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,31 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
-pkgname=emacs-commander
-pkgver=0.7.0
+pkgname=emacs-commander-git
+pkgver=0.7.0r10.gc93985d
pkgrel=1
pkgdesc="Command line parsing for emacs"
arch=('any')
url="https://github.com/rejeep/commander.el.git"
+conflicts=('emacs-commander')
+provides=('emacs-commander')
license=('GPL3')
depends=('emacs')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/rejeep/commander.el/archive/v$pkgver.tar.gz")
-sha256sums=('5eb0f7f016b484ffc91bcd54ced1b0455667e5ee93077a92eafc9d5f4214daa4')
+makedepends=('git')
+source=(git+$url)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd commander.el
+ git describe --tags|sed 's+-+r+'|tr - .|cut -c2-
+}
build() {
- cd commander.el-${pkgver}
+ cd commander.el
emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
}
package() {
- cd commander.el-${pkgver}
+ cd commander.el
install -d "$pkgdir"/usr/share/emacs/site-lisp/
install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/
install -Dm644 README.md "$pkgdir"/usr/share/doc/$pkgname/README.md